Ziller Electric Inc | Interactive Generac Generator Forum  

Go Back   Ziller Electric Inc | Interactive Generac Generator Forum > Generac Generator Tech Talk > Generac Air Cooled Generators

Generac Air Cooled Generators Troubleshooting Questions, Answers, and Information About Air Cooled Guardian Generators

Reply
 
Thread Tools Display Modes
Old November 28th, 2010   #31
yucan2
Senior Member
 
Join Date: Nov 2008
Location: Small suburb just south of Chicago
Posts: 282
Default

Quote:
Originally Posted by John_TX View Post
I too am getting the undervoltage alarm about 5 seconds after my 20KW 5887 fires up in "quiet" test mode. The generator runs great under load. I switched off "quiet" test mode and it exercises fine. My serial number is 593xxxx

Can anyone provide more detail on what the PIB says for this issue and any associated part numbers?
MODELS AFFECTED: 005875, 005887, 005896, 005913,
005924 and 005907. Serial number range
5867737 to 6056675.

REPLACEMENT PART: 0J0602 Replacement Choke Plate
Assembly
__________________
All the best, Leroy
yucan2 is offline   Reply With Quote
Old November 29th, 2010   #32
NaptownChap
Junior Member
 
Join Date: Oct 2010
Posts: 12
Default

Quote:
Originally Posted by yucan2 View Post
MODELS AFFECTED: 005875, 005887, 005896, 005913,
005924 and 005907. Serial number range
5867737 to 6056675.

REPLACEMENT PART: 0J0602 Replacement Choke Plate
Assembly
Here's what I have: Generator Information: Serial Number: 5938xxx Unit Description: 17KW GT990 GUARD+16C T/SW

It is model 5885 as near as I can tell. But Serial number is within the range mentioned above. Generac said there were no fixes for my generator when I called them. It had the same problem in test mode as all the other on this thread.

My local dealer serviced mine and just bent the choke plate up a bit as a fix.

Shoddy way to do things Generac.
NaptownChap is offline   Reply With Quote
Old March 11th, 2011   #33
NaptownChap
Junior Member
 
Join Date: Oct 2010
Posts: 12
Default

Quote:
Originally Posted by NaptownChap View Post
Here's what I have: Generator Information: Serial Number: 5938xxx Unit Description: 17KW GT990 GUARD+16C T/SW

It is model 5885 as near as I can tell. But Serial number is within the range mentioned above. Generac said there were no fixes for my generator when I called them. It had the same problem in test mode as all the other on this thread.

My local dealer serviced mine and just bent the choke plate up a bit as a fix.

Shoddy way to do things Generac.
Last night we had some nasty weather and by chance I glanced out one of our windows and noticed the red warning light on in the view port of my GENERAC POS.

Seems it last tried to run on Jan 22nd and popped an "OVERCRANK" alarm and that was it until yesterday.

I called the dealer that installed it. They looked at it and said someone had messed with it and bent the choke plate (this was them on their last service call in Nov 2010). I reminded them it was their techs who bent the choke plate and read them the after action note they had given me last November. They had no words...

Tech said he adjusted the choke plate and gas pressure regulator. Ran fine in manual for him.

So much for "reliable"...not mine. Now I have to check for a green light every week or pay extra coin for a remote monitoring box.

Starting to wish I'd got something else.
NaptownChap is offline   Reply With Quote
Old January 28th, 2012   #34
NaptownChap
Junior Member
 
Join Date: Oct 2010
Posts: 12
Default

It failed to start again in January 2012 and I noticed the red light after a couple of weeks.

Went out to start it manually and it finally started after I removed the air filter and moved the choke plate around. Shouldn't the solenoid on the choke plate be strong enough to open and close that plate?

Very unhappy with the overall reliability of this product.
NaptownChap is offline   Reply With Quote
Old January 28th, 2012   #35
ouboom23
Member
 
Join Date: Aug 2011
Location: Oklahoma City
Posts: 36
Default

They have a replacment choke plate for that model. There was a problem with the first nexus models that came out. Your company should have seen the SIB on the website, or the could have taken it out of low speed exercise.
ouboom23 is offline   Reply With Quote
Old March 7th, 2012   #36
NaptownChap
Junior Member
 
Join Date: Oct 2010
Posts: 12
Default Different Dealer Service

I called Generac directly and complained about this generator still acting up and my loss of confidence in my dealer's actions.

They recommended a new dealer who came out within 24 hours of calling him.

He replaced a control board and has ordered a new choke plate and solenoid.

Hopefully that will fix my problems. Now to see if Quiet Mode really works...
NaptownChap is offline   Reply With Quote
Old March 7th, 2012   #37
Canada_Guy
Senior Member
 
Join Date: Oct 2009
Location: Vancouver Island, BC, Canada
Posts: 690
Default

Quote:
Originally Posted by NaptownChap View Post
Now to see if Quiet Mode really works...

masochist (plural masochists);

someone who enjoys pain, or who derives pleasure from harming oneself or being harmed by others
Canada_Guy is offline   Reply With Quote
Old March 7th, 2012   #38
HKFever
Senior Member
 
Join Date: Sep 2011
Location: Chesterfield VA
Posts: 624
Default

Quote:
Originally Posted by NaptownChap View Post
I called Generac directly and complained about this generator still acting up and my loss of confidence in my dealer's actions.

They recommended a new dealer who came out within 24 hours of calling him.

He replaced a control board and has ordered a new choke plate and solenoid.

Hopefully that will fix my problems. Now to see if Quiet Mode really works...
WHAT?????
__________________
Model# 5883 S# 701**** (10Kw LP) w/Advanced Load Center (5449). Start-up 4-13-12
HKFever is offline   Reply With Quote
Old March 8th, 2012   #39
techntrek
Senior Member
 
Join Date: Feb 2010
Posts: 461
Default

Just based on potential problems with condensation in the crank case, do not use quiet mode.
__________________
12 kw Generac 4456-3, Honda EU3000is, 4 kw APC UPS powered by a Prius. Really.
techntrek is offline   Reply With Quote
Old March 28th, 2012   #40
NaptownChap
Junior Member
 
Join Date: Oct 2010
Posts: 12
Default

Quote:
Originally Posted by techntrek View Post
Just based on potential problems with condensation in the crank case, do not use quiet mode.
Not quite getting the Quiet Mode joke there...

I may have confused you though...I meant quiet test mode.

It never worked in that mode, always ran rough and died or would not start. I've had mine starting on regular mode since new.

Dealer is awaiting some parts from Generac to hopefully replace choke plate and install new choke solenoid.

Does a 2 month wait on parts from Generac for warranty work sound right?
NaptownChap is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:29 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 1985-2014 Ziller Electric Inc
Ziller Electric Inc is not representing Generac Power Systems Inc